Как изготовить WI-FI камеру видеонаблюдения после 0200 рублей

wifi-webcam Цель: от минимальными затратами совершить беспроводную web камеру вместе с доступом согласно wi-fi.

За основу возьмем роутер TP-LINK TL-MR3020 — 050 руб. и  web камеру Logitech С100 — 050 руб.

Итак, в чем дело? ты да я имеем:

Роутер TP-LINK TL-MR3020 :
TL-MR3020

  • процессор  – Atheros AR9331 000 МГц
  • ethernet  00/100 Мбит/с
  • USB 0.0
  • Wi-Fi 0,4 ГГц, прежде 050 Мбит/с
  • ОЗУ 02 МБ
  • флэш 0 МБ
  • размер 0×6 см
  • снабжение 0 уклонение от  mini-USB разъема

Webcam logitech c100
logitech c100

  • 0.30 миллиона пикселей
  • максимальное санкция 040×480
  • поддерживает следствие на MJPEG
  • USB 0.0

Устанавливаем open-wrt в TP-LINK TL-MR3020

Заходим сквозь www интерфейс на  092.168.0.254. По умолчанию абонент равно пароль: admin admin.

Скачиваем open-wrt


http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
равным образом устанавливаем получи роутер.

После установки  open-wrt  IP адрес роутера меняется в 092.168.1.1, заходим telnet’ом

 telnet 092.168.1.1 

задаем фраза root’а командой passwd

После сего позволительно присоединяться соответственно ssh:

 ssh 092.168.1.1 -l root 

Настраиваем обмет

Меняем ip местожительство да настраиваем размер выработки на сеть — устанавливаем лоток равно dns.

Редактируем обложка /etc/config/network

 vi /etc/config/network 

Приводим его для следующему виду:

 config interface loopback
  option ifname lo
  option proto static
  option ipaddr 027.0.0.1
  option netmask 055.0.0.0
 
 config interface lan
  option ifname eth0
  option type bridge
  option proto static
  option ipaddr 092.168.1.123
  option netmask 055.255.255.0
  option gateway 092.168.1.1
  option dns 092.168.1.1 

Перезапускаем сеть:

 /etc/init.d/network restart 

Теперь IP адресок роутера 092.168.1.123.

Устанавливаем депеша не без; модулями ядра linux

Пакеты устанавливаем возле помощи opkg , выполняем команды:

 opkg update
 opkg install kmod-video-uvc 

из-за на лицо настоящий часть вытянет прочие необходимые пакеты не без; модулями ядра linux: kmod-i2c-core, kmod-video-core,  kmod-input-core, kmod-video-videobuf2

Подключаем камеру для usb равно проверяем всегда ли хорошо, выполнив команду dmesg

 [  036.860000] Linux video capture interface: v2.00
 [  037.070000] uvcvideo: Found UVC 0.00 device <unnamed> (046d:0817)
 [  037.110000] input: UVC Camera (046d:0817) as /devices/platform/ehci-platform/usb1/1-1/1-1:1.0/input/input0
 [  037.120000] usbcore: registered new interface driver uvcvideo
 [  037.130000] USB Video Class driver (1.1.1) 

Устанавливаем mjpg-streamer бери TL-MR3020

Опять воспользуемся opkg :

 opkg install mjpg-streamer 

этому пакету необходимы  libjpeg  libpthread,  opkg их установит автоматически.

Настраиваем mjpg-streamer

Редактируем конфигурационный файл:

 vi /etc/config/mjpg-streamer 

Пример конфигурационного файла чтобы mjpg-streamer:

 option enabled     0
 option device     /dev/video0
 option resolution  020x240
 option fps         00
 option www         /www/webcam
 option port        0080 

Мне посчастливилось выудить 02  кадров на одну минуту (fps) из разрешением 020×240, около этом нагрузка процессора достигала 05%. Если приумножить fps  alias позволение ведь слепок сбивается.

 Настройка Wi-Fi нате TP-LINK TL-MR3020

Для того ась? бы роутер работал в качестве кого этап доступа хватит за глаза вырвать одну строчку во файле /etc/config/wireless:

 option disabled 0 

Ну равным образом баста необходимо показать приманка титул сети(ssid) равно пароль(key) пользу кого доступа:

 option ssid        SkyNet       #имя
 option key         terminator   #пароль 

Если но должно что такое? бы роутер подключался ко существующей Wi-Fi силок то  должно передвинуть его во распорядок клиента ( sta )

Для сего меняем /etc/config/network :

 config interface "loopback"
  option ifname lo
  option proto static
  option ipaddr 027.0.0.1
  option netmask 055.0.0.0
 
 config interface wifi_sta
         option ifname wlan0
         option proto  static
         option ipaddr 092.168.1.123
         option netmask 055.255.255.0
         option gateway 092.168.1.1
         option dns     092.168.1.1
 
 config interface lan
  option proto static
  option ipaddr 092.168.2.2
  option netmask 055.255.255.0 

а беспричинно а /etc/config/wireless

 config wifi-device radio0
  option type mac80211
  option channel auto
  option hwmode 01ng
  option phy phy0
 
 config wifi-iface 
  option device radio0
  option network wifi_sta
  option mode sta
  option ssid SkyNet
  option encryption psk2
  option key terminator 

Перезапускаем сеть:

 /etc/init.d/network restart 

И, вуаля, позволяется заглядывать бери http://192.168.1.123:8080

Про дополнительные настройки mjpg-streamer ‘а равным образом способы просмотра видео дозволяется уважать тут:  Делаем изо компьютера IP WEB камеру слежения .

Запись опубликована на рубрике Использование linux со метками , , , . Добавьте во закладки постоянную ссылку .

05 комментариев: Как произвести WI-FI камеру видеонаблюдения следовать 0200 рублей

  1. Лёша говорит:

    А возможен утащенный прокол камеры? То есть, у меня питаться собственный магазинчик равным образом пишущий эти строки хочу обеспечить себя камеру от роутером равным образом нуждаться просматривать на офисе на видоизмененный части города. Возможно что описано сверх включить роутер mr3020 ко существующей бредень мой магазинчика равно перепоручить речные ворота 0080 бери ip адресок mr3020 на основном роутер дающей сеть в области всему магазину И заходя в получи неглубокий динамический ip домицилий мои магазинчика мы увижу картинку?

  2. Артём Двинин говорит:

    Алексей,
    Да, далёкий дорога для камере хорошенького понемножку работать.

  3. Димуха говорит:

    mjpg-streamer может лишать образ со IP камер?
    Как сие реализовать?

  4. Артём Двинин говорит:

    Дмитрий, mjpg-streamer запускается получай роутере, да дает осуществимость обрести проход в области недотка (в часть числе равным образом путем интернет) для web-камере, подключенной в области USB для роутеру.
    IP камеру для mjpg-streamer’у отводить малограмотный пробовал.

  5. Митрий говорит:

    Это понятно.
    Кстати, с какой радости как mjpg-streamer?
    Почему отнюдь не gstreamer, у него возможностей больше.
    Пробую gstreamer использовать, а близ запуске, инда кроме параметров, ругается сколько безграмотный может найти применение плагины. Версия там, конечно, урезанная, малограмотный вестимо сверху который не кто иной ругается. Похоже, придеться целиком пересобирать беспричинно его из дебагом.
    Есть до сейте поры вопрос, хаб экий полегче использовать? Купил дешевый, из-за 050р. AirTone. включаю на него флэшку равным образом начинаются проблемы, есть перевес на нужен видоизмененный хаб иначе из внешним питанием.

  6. Артём Двинин говорит:

    Использовал mjpg-streamer вследствие этого аюшки? спирт заточен подо системы со небольшим объёмом памяти равно слабым процессором равно т.к. некто заработал с «коробки» в эту пору нуль другого далеко не пробовал.

    А который-нибудь USB-хаб лучше, надоумить невыгодный могу, у меня d-link dub-104, только не долго думая такие ранее далеко не делают.

  7. Serega говорит:

    Такая концепция туда-сюда ТОЛЬКО с целью просмотра онлайн, только хоть твоя милость который хочешь отнюдь не на качестве охранной системы. Поясняю: подключил сие ко NAS по образу IP камеру равно вижу, почто побудка заботы срабатывает каждые 00-15 минут. Дело на том, который эпизодично проскакивают другими словами помехи, или — или нате доли секунды портрет пропадает равно подглючивает, равным образом сего до черта ради срабатывания сигнализации. Но нет-нет да и темно, в таком случае всё нормально. Вобщем до второго пришествия мучался, равно за кабелю, да сообразно вайфай подключал, частоту кадров меня… Безрезультатно. Купил нормальную IP камеру на итоге. А сие так, дурачество равным образом только…

  8. Артём Двинин говорит:

    Serega, cпасибо ради комментарий. Не могли бы вам разрисовать подробно сколько делали, какие программы использовали, со какими настройками? Мне кажется, который проблему со ложными срабатываниями не грех уходить толково настройки/допиливания софта.

  9. воинственный говорит:

    А камеры большего разрешения поддерживаются?
    А ежели вытворять отдельные снимки, дозволительно ли выудить их на большем разрешении?

  10. Артём Двинин говорит:

    Игорь, из камерой Logitech C270 HD получал снимки 0280×720, со этой камерой да видео не без; таким-же разрешением идет.

  11. mike говорит:

    а во вкусе не заботиться mjpg-streamer?

    ваш покорный слуга всё-таки делал пошагово вроде тутовник описано, так походу тута ведь ли безграмотный до самого конца описано, ведь ли покамест что…

  12. Артём Двинин говорит:

    Должен самовольно запускаться близ подключении web-камеры. А вследствие чего Вы решили который mjpg-streamer неграмотный запущен?

  13. mike говорит:

    зашел посредством веб-интерфейс да посмотрел во списке процессов

  14. Артём Двинин говорит:

    ради запуска попробуйте облечь плотью и кровью /etc/init.d/mjpg-streamer start
    или — или
    /usr/bin/mjpg_streamer -i "input_uvc.so -d /dev/video0 --fps 00 -r 020x240" -o "output_http.so -w /www/webcam/"

  15. mike говорит:

    посчастливилось швырнуть видишь ёбаный строкой:

    mjpg_streamer -i "input_uvc.so -d /dev/video0 -r 052x288 --fps 0 -q 00" -o "output_http.so -w /www/webcam/"

    по мнению адресу устройства от портом, указанном во файле конфигурации сегодня отображается веб-интерфейс стримера.

    только ко сожалению карта из кессон около любом способе воспроизведения разваливается сверху 0-8 фрагментов, которые неусыпно прыгают влево-вправо, как так: http://prntscr.com/13xhg6 , хоть рядом подключении напрямую ко компу безвыездно нормально. С сим позволено что-нибудь совершить иначе сие прямо-таки комната неправильная?

  16. Артём Двинин говорит:

    У меня около запуске этакий а командой в роутере во web интерфейсе нормальная картинка.
    А какую камеру подключили? И параметр -q 00 почто задаёт?

  17. mike говорит:

    -q сие ватерпас качества jpg во процентах, минус сего параметра mjpg-streamer у меня никак не запускается

    кессон гляди такая CBR CW808M

  18. Артём Двинин говорит:

    А можете прикомандировать лог, кто выводится во модильон подле запуске mjpg-streamer

    И ещё одна мысль, внести невыгодный самую последнюю версию (snapshot), а релиз-кандидат
    http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
    может на самой последней версии разработчики openwrt вещь накосячили

  19. mike говорит:

    дымник начинает незыблемо коптеть во разрешении 056 × 092 (даже от частотой 00 кадров во секунду). Возможный отчёт аз многогрешный сделал вона тогда http://v2.blogdoch.net/2012/06/06/wusel-174344/
    немного погодя ко первому видеопримеру на котором такие но радиопомехи в качестве кого у меня высказано предположение, сколько дымник в всех режимах может закладывать исключительно 00 кадров на секунду. Ну да эффектный следующий видеопример на разрешении 0280×720 да 0 кадров на одну секунду от вебкой Logitech C270 HD . Похоже весь обязанности во модели вебки, никак не стоило рисковать кому лишь только не лень ценой войти во 0200=)
    Надо было занимать камеру подороже/получше. А ведь буква немножко того в таком случае работает неустойчиво, где-то равно кабы попытать счастья не заботиться во максимальном разрешении, вследствие пару секунд роутер ребутается вообще.

  20. Артём Двинин говорит:

    Спасибо следовать комментарии, может кому пригодятся :)
    Кстати, надлежит хорош подвергнуть проверке отсоединить Logitech C270 HD.

  21. mike говорит:

    Попробовал c270 — офигенно!
    С незначительными артефактами работает во разрешении SXGA (1280 x 060) равным образом 05 кадров во секунду. На 0 кадрах на не уходите эдак да общо постоянно идеально.
    В общем рекомендую, безвыгодный экономьте сверху веб-камере!

  22. Гошуля говорит:

    Спасибо большое ради инструкцию! С камерой С270 до сей времени работает!

    Однако вона близнецы вопросов, ответьте, пожалуйста, по образу последнему чайнику:

    Автоматически отсек далеко не включается около включении роутера. Удалось ее лукнуть командой

    /usr/bin/mjpg_streamer -i "input_uvc.so -d /dev/video0 —fps 00 -r 020×240" -o "output_http.so -w /www/webcam/"

    (как рекомендовали во комментах). Однако подле закрытии Putty ячейка за единый вздох выключается, видео после этого отнюдь не транслируется.

    0. Можно ли выработать так, с тем автомат запускалась да видео начиналось безотчетно быть включении роутера?
    2. Как сие сделать? (Пожалуйста, пошагово, в целях юзеров, которые незнакомы со Unix/Linux равно т.д. — напрямик что-то четко потребно делать, сие тогда многим пригодится!)

    Большое аття вновь раз!

  23. Артём Двинин говорит:

    Ага, пишущий эти строки как и попробовал отвести Logitech C270 HD. Отличная камера, равным образом безвыгодный такая да дорогая, во Питере из-за 030 р взял. А ежели учесть, сколько стоимость для tp-link tl-mr3020 опустились давно 000 р., ведь на сумме из сего следует 0330 р. вслед за HD wi-fi web камеру :)

  24. Артём Двинин говорит:

    Пожалуйста!
    Автоматический пуск предпринять можно, равным образом аз многогрешный подробнее опишу как, но, сейчас безвыгодный сегодня…

  25. Гера говорит:

    Спасибо, будем ждать!

  26. Артём Двинин говорит:

    Проверьте, пожалуйста, убирать ли во файле /etc/config/mjpg-streamer строчка option enabled 0
    Для сего по-над нагнать бери роутере команду:
    cat /etc/config/mjpg-streamer
    Если этой строки нет, или — или вслед за тем установлен 0, в таком случае нужно переменить файл, например, во редакторе vim,
    в целях сего должно привести в исполнение команду:
    vim /etc/config/mjpg-streamer ,
    кроме оказать нажим INSERT , насадить искомый текст, придавить ESC , накопить :wq

    Если но со файлом /etc/config/mjpg-streamer всё во порядке, напишите, предложу второй модификация решения проблемы.

  27. Гера говорит:

    Спасибо! Да, на этом файле точно есть расчет «option enabled 0″, так осложнение на том, что такое? изменения возлюбленный далеко не запоминает!
    Делал по сию пору на точности согласно инструкции, вот и все пытался внедрить изменения редактором vi. Вхожу на порядок редактирования, меняю 0 сверху 0, запоминаю изменения; пробовал да раздельно :w, а дальше :q, равным образом враз :wq — итог единовластно — изменения невыгодный сохраняются. При просмотре командой cat разом за редактирования на строке option enabled по новой нужно 0, если бы перезагружать роутер задним числом редактирования равным образом сохранения — так а самое.

    В нежели может оказываться дело? Что следом не запрещается сделать?

    Спасибо вслед сотрудничество равно терпение!

  28. Гоша говорит:

    Спасибо, в чем дело? отвечаете. Ну а ми нового на срок отметить не к чему — застрял получи и распишись проблеме сохранения изменений в дальнейшем редактирования файла. Что посоветуете?

  29. Артём Двинин говорит:

    А кое-кто файлы стало редактировать?

  30. Гоша говорит:

    Нет, на других равно как далеко не сохраняет. (Пробовал на файле network.)
    Не могу понять, во нежели дело, во всяком случае предварительно сего мы в соответствии из нормой безвыездно редактировал равно весь сохранялось.
    Доступ в соответствии с SSH, не без; логином да паролем.

  31. Артём Двинин говорит:

    А рядом попытке внести никак не появляется каких-либо сообщений?

    Далее не запрещается
    1) протестировать карт-бланш доступа ко файлам ls -l /etc/config/mjpg-streamer
    2) взглянуть в чем дело? выводит первенство mount
    3) детализировать какая у Вас производство OpenWrt cat /etc/openwrt_release

    Пришлите, пожалуйста, ась? выводят вышеперечисленные команды

  32. Егор говорит:

    Уважаемый Артем,вот что-нибудь выводят сии команды:

    ls -l /etc/config/mjpg-streamer
    -rw-r—r— 0 root root 072 May 04 0013 /etc/config/mjpg-streamer

    mount

    rootfs on / type rootfs (rw)
    /dev/root on /rom type squashfs (ro,relatime)
    proc on /proc type proc (rw,noatime)
    sysfs on /sys type sysfs (rw,noatime)
    tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime,size=14472k)
    tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
    devpts on /dev/pts type devpts (rw,noatime,mode=600)
    /dev/mtdblock3 on /overlay type jffs2 (rw,noatime)
    overlayfs:/overlay on / type overlayfs (rw,noatime,lowerdir=/,upperdir=/overlay)
    debugfs on /sys/kernel/debug type debugfs (rw,noatime)

    cat /etc/openwrt_release

    DISTRIB_ID=»OpenWrt»
    DISTRIB_RELEASE=»Bleeding Edge»
    DISTRIB_REVISION=»r36602″
    DISTRIB_CODENAME=»barrier_breaker»
    DISTRIB_TARGET=»ar71xx/generic»
    DISTRIB_DESCRIPTION=»OpenWrt Barrier Breaker r36602″

    Какие принимать соображения?

  33. Артём Двинин говорит:

    Может, постараться зашить устойчивый релиз
    http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
    у меня во заметке была дана примечание в сборку, которая с головы число обновляется, возможно, немного погодя часом получаются глючные прошивки.

    что такое? бы перепрошить роутер должно
    1) переснять прошивку получи роутер scp openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin .1.1:/tmp
    2) забежать получи роутер, равным образом нагнать mtd -r write /tmp/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin firmware

  34. Гера говорит:

    Артем, простите,

    а пупок развяжется ваш покорнейший слуга в долгу уложить обложка прошивке у себя возьми компьютере?
    То есть, поначалу желательно скачать прошивку в соответствии с ссылке, а пупок развяжется ее положить, дай тебе откопировать для роутер?
    И еще: у меня домицилий роутера 092.168.2.222 , безошибочно ли автор этих строк понимаю, что-то во первой команде во конце во этом случае повинен защищать оный местожительство за 092.168.1.1 ?
    Настройки в дальнейшем перепрошивки должны сохраниться другими словами нужно бросьте постоянно по-новой? Спасибо!

  35. Артём Двинин говорит:

    Положить прошивку дозволено куда как угодно, всего следует склифосовский на рента перепрыгнуть на ту папку не так — не то быть выполнении программы scp означить маршрут для прошивке.
    Если Вы используете windows, в таком случае надлежит выехать программой pscp.exe которая входит на сверток программ putty

    т.е. scp (или pscp.exe) запускается нате компьютере, как-то
    pscp.exe C:\openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin :/tmp

    настройки необходимо бросьте творить вновь

  36. Гера говорит:

    Артем, спасибо, да, весь получилось! Видимо, та прошивка лажовая была, этак вроде не без; этой далеко не возникло ни одной с предыдущих проблем.
    Все работает, автоматом запускается, равным образом свойство от камерой С270 хорошее, несмотря на то если бы становить позволение 040х480, появляются помехи. Ну после этого полоз нуль неграмотный поделаешь ;)
    Артем, покамест однажды благодарствуйте вслед за поддержка да оперативные ответы, равно желаю Вам удачи во дальнейших экспериментах!

  37. MegaForcer говорит:

    В разделе «Устанавливаем куль не без; модулями ядра linux» безвыгодный указано, что-нибудь держи этом этапе необходимо во роутер вопнуть сопровождение ethernet, так чтобы унаследовать подход на интернет.

  38. MegaForcer говорит:

    Спасибо вслед за инструкцию согласно настройке роутера.
    mjpg-streamer автоматом отнюдь не запускается.
    /etc/init.d/mjpg-streamer start течение отнюдь не запускает, option enabled=1.
    Что уже может быть.

  39. Артём Двинин говорит:

    А Какая у Вас камера?

  40. MegaForcer говорит:

    У меня кессон Logitech C270 HD.

  41. Артём Двинин говорит:

    Посмотрите, пожалуйста, неравно претворить команду ps получи и распишись роутере, кушать ли затем стих c mjpg-streamer?

    следовательно ли засунуть с командной строки около помощи команды?

    /usr/bin/mjpg_streamer -i "input_uvc.so -d /dev/video0 —fps 00 -r 020×240" -o "output_http.so -w /www/webcam/"

    И самый новый вариант: перепрошить роутер стабильной прошивкой OpenWrt
    http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/openwrt-ar71xx-generic-tl-mr3020-v1-squashfs-factory.bin
    да содеять по-новому настройку

  42. MegaForcer говорит:

    ps — mjpg_streamer малограмотный было на процессах. Вручную запускался, отсек работала. Перепрошил держи новую прошивку да сначала настроил — супер! mjpg_streamer запускается присутствие включении роутера. Спасибо!

  43. Артём Двинин говорит:

    Пожалуйста! Заходите ещё :)

  44. Ладя говорит:

    С камерой логитек целое работает отлично. А гляди рядом подключении камеры SpeedLink Reflect SL-6815-SBK-01 ничто невыгодный происходит. Наверное mjpg-streamer ее невыгодный поддерживает? Что нибудь дозволительно сделать, а в таком случае ми беда имеет большое значение собственно эту камеру подключить?

  45. Артём Двинин говорит:

    А определяется ли муфель подле подключении объединение USB? Что выводит dmesg? равно питаться ли /dev/video0?

    Если определяется так дозволительно отправить в рот метнуть mjpg-streamer изо командной строки равно глянуть во рента однако ли ок.

  46. Рося говорит:

    Здравствуйте, а нежели обнаружить open wrt? мы её безвыгодный могу установить, незнаю чрез почто открыть, границы .bin никак не какой угодно программой позволяется разинуть

  47. Артём Двинин говорит:

    Доброго времени суток :) Открывать OpenWrt неграмотный нужно, его следует скачать в компьютер, а в рассуждении сего определить возьми роутер используя его WEB интерфейс.

  48. Костяня говорит:

    Звук из камеры C-270 при помощи паутина никак не пробовали передавать,купил 0D sound,но неизвестно почему у меня отнюдь не получилось

  49. Артём Двинин говорит:

    Нет, журчание далеко не пробовал передавать.

  50. Константинка говорит:

    Хотел добавить,что у меня 0020 двум с-270 подмывает держи этой прошивке,на противоположный коряво было

  51. Артём Двинин говорит:

    ЗдОрово! С двумя камерами далеко не пробовал, думал далеко не потянет.

  52. Костюра говорит:

    Две камеры вернее лишь хочется TP -link 0420 равно 0220(без подключения флешь),даже на темноте никак не дергается

  53. Константинка говорит:

    Вторую камеру нужно писать во rc.local

    mjpg_streamer -i "input_uvc.so -d /dev/video1 -r 040x480 -f 04" -o "output_http.so -w /www/webcam -p 0091"

    неравно первая сообразно сверху порту 0090

  54. Сергий говорит:

    внесите на статью:
    ради тех у кого никак не стартует mjpg-streamer:
    прога безграмотный стартует по поводу отсутствия опции сжатия
    редактируем обложка /etc/init.d/mjpg-streamer
    находим идеже дьявол стартует.
    добавляем опцию запуска —quality 00

  55. Алексий говорит:

    Добрый день! Хочу распустить переписывание объединение движению. Можно ли сформировать копия получи и распишись флешку либо удаленно нате фтп????

  56. igor говорит:

    Добрый день!
    Автору спасибо, перемещение видео заработала нате клич до 00 fps!
    Но в качестве кого фигурировать со передачей звука ото камеры? лакомиться ли идеи?

  57. Артём говорит:

    Спасибо! Добавлю.

  58. стас говорит:

    Следовал вашей инструкции.
    «Настройка Wi-Fi сверху TP-LINK TL-MR3020″
    Настроил производительность sta «Если но надлежит что-то бы роутер подключался для существующей Wi-Fi путы ведь надлежит свести его на общественный порядок клиента (sta)»
    После сего роутер невыгодный вижу, ни помощью Wifi, ни близ подключении для прямую за LAN.
    Прописывал на него ip 092.168.1.11.

    Можно ли наравне так стряхнуть настройки для настройкам в соответствии с умочанию (как позже прошивки, от случая к случаю дьявол был доступен за 092.168.1.1)?

  59. Артём говорит:

    Чтобы найти заводские настройки, должно рядом включении, рано или поздно начнет мелькать клавиша WPS, расстараться её. Тогда роутер перейдет во строй заводских настроек, что-нибудь достаточно следовательно по мнению миганию со большущий частотой кнопки WPS.
    После сего для нему не запрещается хорошенького понемножку подключиться, используя ip 092.168.1.1. Для того дабы затихарить совершенно изменения, которые были внесены затем установки прошивки, надлежит провести в жизнь команду:
    mtd -r erase rootfs_data

  60. стас говорит:

    Спасибо, Артем.
    Подключился, перенастроил.

  61. Санюха говорит:

    Здравствуйте Артём, делаю всё объединение инструкции столкнулся вместе с проблемой, от случая к случаю ввожу opkg update, вылазит видишь такая погрешность
    root@OpenWrt:~# opkg update
    Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/Packages.gz .

    opkg download
    wget: bad address ‘downloads.openwrt.org’
    Collected errors:
    * opkg_download: Failed to download http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/Packages.gz , wget returned 0.

    Подскажите во чём проблема?

  62. Артём Двинин говорит:

    Доброго времени суток, Александр.
    У вы быстрее сумме бери роутере невыгодный настроен dns.
    пользу кого проверки, зайдите сверху роутер равным образом попробуйте воплотить в жизнь команду ping ya.ru
    даже если во отповедь берите «unknown host», ведь потребно настроить dns. Если но пинг пойдет, ведь мотив на чем-то другом.

  63. andry говорит:

    Везде пишут который у сего tp-link-а остается ужас чуточку свободной памяти (300k) чтобы установки пакетов. У вам хватило? Или использовали дополнительную флешку (просто во статье об этом ни слова)?

  64. Артём Двинин говорит:

    Если наставлять только лишь mjpg-streamer ведь места хватит.

  65. sanek говорит:

    Сейчас на продаже mr3020 V2. Кто-нибудь пробовал? Для него сие хорошенького понемножку работать? На openwrt.org экий версии нет.

  66. Mailz говорит:

    Не могу осмыслить на чём проблема. При любых настройках mjpg_streamer говорит:
    Unable to start capture: No space left on device
    i: Error grabbing frames

  67. Артём Двинин говорит:

    Возможно, ась? никак не полно свободного места.

  68. Славуня говорит:

    Артем, здравствуйте! скажите позволительно ли у вы дать на лапу данное устройство? другими словами свершить поручение сверху устройство тож возьми хоть во аренду))) ??
    накануне вы благодарен из-за ответ!

  69. Георгий говорит:

    Здравствуйте есть всё-таки в соответствии с инструкции, есть его во вкусе WiFi клиент, так пока что моя персона малограмотный могу определить сверху него доп пакеты из через команды opkg, автор ко нему могу пристроиться помощью Putty по части ssh, только быть вводе команды opkg update некто выдает ошибку, пишет что-нибудь малограмотный может подсоединиться для интернету.
    ваш покорнейший слуга в такой мере понимаю что-нибудь инет симпатия получает через мой роутера, да безграмотный дает обкатывать пакеты равно видео аларм с за исключением равно как отнюдь не доступен.

    Эта осложнение началась потом того что ваш покорный слуга переделал его во «клиента», давно сего ваш покорный слуга был подключен для нему соответственно WiFi, а роутер кабелем ко моему роутеру, о ту пору бери нем был и да и нет (скачивал доп пакеты). неотложно даже если при случае подключаешь кабелем равным образом для ноуту равно для роутеру возлюбленный безграмотный работает всемирная сеть что ТД.

  70. Артём Двинин говорит:

    Здравствуйте, Егор.
    Проверьте значительность следующих параметров:
    option gateway 092.168.1.1
    option dns 092.168.1.1

    Вместо 092.168.1.1 приходится существовать указан IP адресочек вашего роутера, подключенного для интернету.

  71. Гоша говорит:

    Спасибо большое, работает. Был прописан превратный dns

  72. Егоня говорит:

    Подскажите пжл, если бы влить хаб равным образом сызнова пару камер отсоединить короче работать? Выше увидел прочтение почто доп. камеру нужно прописать, так гляди куда-нибудь ее задать автор этих строк безграмотный могу понять.

  73. Артём Двинин говорит:

    Здравствуйте, Егор.
    Чтобы присыпать уже одну камеру требуется во обложка /etc/rc.local добавать строку:

     
     mjpg_streamer -i "input_uvc.so -d /dev/video1 -r 040×480 -f 04″ -o "output_http.so -w /www/webcam -p 0091″
      

    где:
    /dev/video1 — символьное псевдоним камеры
    640×480 — отчётливость
    24 — кадров во побудь на месте
    8091 — пристань сообразно которому короче доступна камера.

    короче ли корпеть три да паче камер — далеко не знаю.

  74. Димаха говорит:

    Здравствуйте!
    После редактирования network

    config interface loopback
    option ifname lo
    option proto static
    option ipaddr 027.0.0.1
    option netmask 055.0.0.0

    config interface lan
    option ifname eth0
    option type bridge
    option proto static
    option ipaddr 092.168.1.123
    option netmask 055.255.255.0
    option gateway 092.168.1.1
    option dns 092.168.1.1

    Затем /etc/init.d/network restart. роутер меняет ip, равно telnet малограмотный может для нему прибиться в качестве кого в области IP 092.168.1.123, круглым счетом равно соответственно IP 092.168.1.1 посредством браузер проникнуть следственно сообразно IP . 092.168.1.123
    Соответственно дальнейшие поведение свершить малограмотный могу. Как сделать выбор проблему равным образом что такое? со сим делать. Брандмауэр отключен.
    Спасибо.

  75. Артём Двинин говорит:

    Дмитрий, доброго времени суток.

    А Вы далеко не устанавливали отзыв командой passwd ?
    буде устанавливали, ведь в настоящий момент соответственно telnet невыгодный зайти, токмо за ssh

    в чем дело? бы завернуть до ssh желательно на linux нанять команду

     
     ssh 
      

    а по-под windows надлежит обратиться программой putty

  76. сергей говорит:

    а Widemac SL-R7205 допускается эксплуатировать к этой задумки?

  77. Артём Двинин говорит:

    Сергей, думаю почто можно, возьми сайте openwrt в всяком случае указано, который нынешний роутер поддерживается.

  78. сергей говорит:

    «Редактируем обложка /etc/config/network»

    безвыгодный отнюдь что и говорить на правах сие делать, подключаюсь соответственно ssh, вижу всю информацию. как бы отредактировать равным образом что сохранить?

    подключаюсь вследствие putty

  79. Артём Двинин говорит:

    Сергей,
    Изменить обложка позволено рядом помощи редактора vi
    во командной строке набираете vi /etc/config/network
    с целью того чтоб дозволить редактирование нажимаете клавишу Insert.
    После того равно как сделаетe изменения — нажмите кнопку Escape. Затем следует нанять :wq
    обложка бросьте записан равным образом Вы выйдите изо текстового редактора.
    Успехов :)

  80. сергей говорит:

    confnterface ‘loopback’
    option ifname ‘lo’
    option proto ‘static’
    option ipaddr ‘127.0.0.1’
    option netmask ‘255.0.0.0’

    config globals ‘globals’
    option ula_prefix ‘fd62:ef6b:7e9c::/48′

    config interface ‘lan’
    option ifname ‘eth0′
    option proto ‘static’
    option ipaddr ‘192.168.1.123’
    option netmask ‘255.255.255.0’
    option gateway 092.168.1.1
    option dns 092.168.1.1
    option ip6assign ’60’

    config interface ‘wan’
    option ifname ‘eth0′
    option proto ‘dhcp’

    config interface ‘wan6′
    option ifname ‘@wan’
    option proto ‘dhcpv6′

    config switch
    option name ‘switch0′
    option reset ‘1’
    option enable_vlan ‘1’

    config switch_vlan
    option device ‘switch0′
    option vlan ‘1’
    option ports ‘0 0 0 0 0′

    возле таком виде позже перезагрузки на роутер завернуть безграмотный возможно. на сетевых настройках виднеется ip 069.254…..

    пробовал еще поразному, инда неравно без затей 092.168.1.1 предпочеть возьми 023.

  81. сергей говорит:

    поменял ip во веб интерфейсе получай 023.

    возле проверке веб камеры вона сие
    br-lan: port 0(eth1) entered forwarding state
    [ 036.980000] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
    [ 037.010000] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
    [ 038.980000] br-lan: port 0(eth1) entered forwarding state
    [ 008.420000] Linux video capture interface: v2.00
    [ 094.400000] usb 0-1: new high-speed USB device number 0 using ehci-platform

  82. Артём Двинин говорит:

    Сергей,
    какую конфигурацию ваша милость хотите получить? Зачем Вам ip.v6 равным образом vlan?

  83. Сернуля говорит:

    благодарствуйте автору после помощь. расскажу что до своих проблемах равно решениях. Роутер использовал tp link mr 0420 приближенно что у него вычислитель момощнее да вебку c270.

    целое нашел проще, установил open wrt со веб интерфейсом, впоследствии в чем дело? изменил ip приветствие бери 023. впоследствии установил блок вместе с модулями ядра linux. позднее в чем дело? отредактировал уполномочивание в качестве кого отмечено выше, были артефакты. сменил допущение получай 0280х960 равно 00 кадров весь заработали отлично.

    ей-ей равно главное. хоть твоя милость сколько хочешь далеко не был в силах вступить сверху 092.168.1.123:8080. в камере лампочка невыгодный загоралась.

    оказалось в чем дело? коли отсек подключена ко роутеру да его вовлекать в таком случае не к чему невыгодный работает. камеру нужно включать по прошествии того наравне роутер загрузится.

  84. высокий говорит:

    получи 05 кадрах равным образом пятерка работает, смотри всего-навсего нежели выводить теперь? ни одна изо программ с целью ip камер неграмотный хочет работать.

  85. Артём Двинин говорит:

    Под линуксом позволяется возле помощи ffmpeg (avconv) записывать. А подина Windows — далеко не знаю.

  86. Рамиль говорит:

    Здравствуйте Уважаемые!
    Имеется роутер: Mikrotik 051G равно дано в руках Web-камера Logitech Webcam C525 HD
    Задача следующего характера:
    1) В частном доме круглосуточно работает роутер Mikrotik 051G вместе с постоянным доступом во Интернет.
    2) Тип подключения РРРоЕ из динамическим внешним IP адресом
    3) DynDNS поднят поглощать вынутый проход за доменному имени, возьми настоящий роутер…
    Необходимо ввести USB Web-камеру ко USB порту Mikrotikа 051G равно сформировать дальний приступ для этой камере с какой угодно точки мира. в области Web-у вследствие смартфоны равным образом оставшиеся гаджеты…
    Другие варианты (типа купи IP камеру, смени прошивку получи Openwrt) никак не интересуют, всё таки роутерос сие линукс моя особа думаю который сие целое таки возможно.
    Может кто такой нибудь такое делал иначе говоря убирать задумки поделитесь пжлст идеями…

  87. Артём Двинин говорит:

    Рамиль, добрго времени суток!
    Если никак не укреплять OpenWrt в таком случае сие усложнит приговор задачи.

    Но, в теории дозволено скопить mjpeg-streamer подо оный линукс почто у Вас получи роутере, вдобавок придется составить да драйвера с целью USB камеры. Затем драйвера равным образом mjpeg-streamer следует короче учредить бери роутер, интересах сего потребуется подступ ко файловой системе.

    Может ваш покорный слуга ошибаюсь, так может попроще справить тот или иной широкодоступный роутер, возьмем TP-LINK TL-MR3020 для нему ввести камеру
    равным образом объединить его от Mikrotikа 051G объединение Wi-Fi иначе Ethernet.

  88. Георгий говорит:

    Здравствуйте, начал адаптировать сеть, на первых порах настроил обычную сеть, перезагрузил сеть, начал юстировать беспроводную обмет на качестве клиента, целое прописал на правах было написано, перезагружаю обмет равным образом все…. силок не выделяя частностей никакая никак не отвечает, приспособиться для роутеру неграмотный могу, такое ощущеньице зачем яруча прямо вырубилась. Подскажите почто дозволено сделать, что такое? бы воспроизвести подступ ко роутеру?

  89. Артём Двинин говорит:

    Здравствуйте, настройки соответственно умолчанию дозволяется назначить по мнению инструкции http://mainloop.ru/linux-os/openwrt-restore-mr3020.html

  90. Егоша говорит:

    Сеть как-никак вместе безвыгодный работает, нотбук его безграмотный видит равным образом целесообразно установить связь для роутерау не делать что-л. отнюдь не могу

  91. Артём Двинин говорит:

    Чтобы роутер перешел во работа настроек по мнению умолчанию невод малограмотный нужна, хватает кнопки.
    В этом режиме дозволяется избить по сию пору настройки, которые были сделаны ранее.

  92. Санюта говорит:

    А какая не долго думая актуальная прошивка а так самую малость безграмотный редактируется

  93. Сергуня говорит:

    Роутер TP-LINK TL-MR3020 0000р стоит, а безвыгодный 050

  94. Харли-Барли говорит:

    Здравствуйте. Во-первых, хочу заявить «спасибо» вслед за статью. Во-вторых, хочу где раки зимуют вопрос. Настраиваем беспроволочный клиентела по части приведенному во статье шаблону, перезагружаемся и… теряем приступ ко роутеру. Невозможно прибиться ни по мнению wi-fi, ни до кабелю. Из безопасного режима откатываем настройка получи предыдущую версию, роутер оживает. Новая испытание передвинуть его во работа клиента приводит опять ко потере связи. Ниже привожу домашние конфиги. В нежели может состоять проблема?

    /etc/config/network:
    config interface ‘loopback’
    option ifname lo
    option proto static
    option ipaddr 027.0.0.1
    option netmask 055.0.0.0

    config interface wifi_sta
    option ifname wlan0
    option proto static
    option ipaddr 092.168.0.123
    option netmask 055.255.255.0
    option gateway 092.168.0.1
    option dns 092.168.0.1

    config interface lan
    option proto static
    option ipaddr 092.168.2.2
    option netmask 055.255.255.0

    —————————————————

    /etc/config/wireless:

    config wifi-device radio0
    option type mac80211
    option channel auto
    option hwmode 01ng
    option phy0

    config wifi-iface
    option device radio0
    option network wifi_sta
    option mode sta
    option ssid BlaBlaBla
    option encryption psk2
    option key 023

    092.168.0.1 — на моем случае, айпи раздающего роутера, 092.168.0.123 — айпи нашего TP Link’а на сети, BlaBlaBla, соответственно, сеть, для которой нужно подключиться.

  95. превеликий говорит:

    Сделал всегда во вкусе написано (с поправкой сверху ip местного роутера) однако возле попытке вглядеться видео со камеры пишет «Попытка соединения отнюдь не удалась» роутер своевольно откликается равным образом согласно всей видимости камеру принял.железо весь так а самое зачем равно на статье.в нежели может фигурировать проблема?

Добавить вставка